Finding and Editing Objects

- Finding Objects
- Editing Objects
- Copying and Duplicating Objects
- Pasting Objects
- Deleting Objects
- Undoing Operations
Finding Objects

You can use the Edit > Find command to search for geometric objects or for ports or instances of a particular name.

To search for a geometric object(s), check the box next to the type of object: Box, Circle, Polygon, Ruler, or Wire. Ports and instances are searched for by name. Instances can be searched for by Instance name or Cell name. Checking the Match whole names only or Match case check box for ports or instances further...
restricts the search. If the name field is left blank, all ports or instances that satisfy the search criteria are found.

Objects and ports can be searched for on a specific layer by selecting a layer from the On layer drop-down list. If the field is left blank, objects and ports will be found on any layer where they occur.

Multiple items can be searched for with a single execution of the command. For example, if you choose Poly from the layer list and check the Box and Port check boxes with Gnd in the Port field, L-Edit finds all boxes and all ports named Gnd on layer Poly. Objects are searched for in the order shown in the dialog: geometric objects, then ports, then instances.

When an object is found it is automatically selected. Clicking the Find Next button finds the first occurrence; clicking the Find All button finds and selects all objects simultaneously that match the specified criteria. Three options are provided for viewing the layout when the items are found: No change, Pan, or Pan & zoom. When no objects are found, a dialog with the message, Cannot find specified object(s), is presented.

**Note:** If only a single item is found, the search successfully terminates with that item.

Search parameters in the Find Object(s) dialog are “remembered” during an L-Edit session and are used for all subsequent Find operations. The search parameters are not cleared when you switch between cells and files.
Find Next/Find Previous

When an object has been found, you can search for the next object or for the previously found object. The Edit > Find Next and Edit > Find Previous commands use the current search parameters regardless if they were set during a Find operation in the current cell or a different cell or file.

The Find Next and Find Previous commands select objects in a circular manner. When the last object matching the search parameters is found, the search is continued from the first object found.
Editing Objects

You can edit objects in two ways: by modifying their characteristics textually (see Textual Editing), or by using the mouse to change them graphically (see Graphical Editing).

Graphical Editing

Objects in L-Edit can be graphically edited with a combination of mouse and keyboard buttons. You can resize and reshape objects, perform stretch editing, add vertices to polygons or wires, slice, merge, and nibble objects.

Resizing and Reshaping

Objects can be resized or reshaped. For boxes, ports, and polygons, resizing or reshaping consists of moving a vertex or an edge to change the object’s dimensions. For circles, the circumference is moved to change the radius. For wires, you can only adjust the vertices or length. Changes to width are handled by textual editing (see Textual Editing).

An object must be selected to be resized or reshaped. If no objects are selected, then clicking the MOVE/EDIT button near the object implicitly selects it temporarily; the object is automatically deselected after the operation. Position the pointer on or just inside or outside of a vertex or edge of the object and drag
the mouse to change the object’s dimensions. The distance of the pointer from the edge or vertex that differentiates between a move and edit operation is set in
the Edit range fields in the Setup Design – Selection dialog.

**Stretch Editing**

Multiple boxes, polygons, wires, or ports can be resized or reshaped at one time by selecting and moving sets of their edges.

To select only the edge of an object, hold the SELECT EDGES (Ctrl+SELECT) mouse button and drag a selection box around the edge(s) of the object(s) you wish to edit. (See Explicit Selection for information on selecting objects by dragging.) The selected edges and any objects completely enclosed by the selection box are selected and will appear highlighted.

The selection can be extended to other edges by dragging around them with the EXTEND SELECT EDGES (Shift+Ctrl+SELECT) mouse button. Individual edges can be subtracted from the selection set by clicking over them with the EXTEND UNSELECT EDGES (Ctrl+Alt+SELECT mouse button).

To modify the selected object(s), drag the edges in the desired direction with the MOVE/EDIT mouse button. All selected edges and objects will move the same direction and distance, subject to any constraints imposed by the objects themselves. Holding the Shift key with the MOVE/EDIT mouse button enables snapping, where edges can only be moved in the horizontal or vertical directions.
Adding Vertices

You can add a vertex to an all-angle polygon or wire. To add a vertex, position the pointer on the edge where you want the new vertex and hold the Ctrl+MOVE/EDIT mouse button while dragging the new vertex into position.

Slicing

L-Edit allows you to divide selected objects into separate parts with the Draw > Slice > Horizontal and Draw > Slice > Vertical commands. After invoking the Slice command, a horizontal or vertical line will appear indicating where to slice (divide) the objects. The line moves with the pointer until any mouse button is clicked. Each selected object is split into two new objects with coincident edges at the location where the slice line was dropped. If all selected objects are not in the current view, the view is zoomed to include all objects.

Merging

You can merge multiple selected and intersecting boxes, polygons (45° and 90° only), or wires (45° and 90° only) on the same layer into one object with the Draw > Merge command.

Objects from more than one layer may be selected. For each layer, L-Edit merges each set of overlapping selected objects into one object.
**Note:**

Only intersecting objects on the same layer can be merged.

---

**Nibbling**

To *nibble*, or cut out, a polygonal area from a set of objects, select the objects first, then select the drawing tool that will be used for nibbling and invoke the **Draw > Nibble** command. Draw the shape to nibble as you would a normal object. When you finish, this shape is deleted from the objects you selected before you began. Both the nibbling tool and any nibbled object must be a box, polygon (45° and 90° only), or wire (45° and 90° only). When using a wire as a nibbling tool, the **Drag Box** layer’s default wire width needs to be set in the **Setup > Layers** dialog to the width of the nibbling wire. If it is zero, nibbling is not allowed with wires.

Objects from more than one layer may be selected, but each object is nibbled separately. Objects that cannot be nibbled (circles, ports, and all-angle polygons and all-angle wires) are ignored.

**Textual Editing**

In addition to being edited graphically, objects in L-Edit can be edited textually with **Edit > Edit Object(s)**.
The **Edit Object(s)** dialog contains seven tabs: **Boxes, Polygons, Wires, Circles, Ports, Rulers, and Instances**.

**Boxes**

The coordinates of a box, the data type, and the layer it resides on are changed through the **Edit Object(s) – Boxes** tab.
Polygons

A polygon’s vertices, the data type, and the layer it resides on are modified with the **Edit Object(s) – Polygons** tab. Vertices can also be added and deleted.
Wires

Wires are edited with the Edit Object(s) – Wires tab. You can change vertices, add and delete them, change the data type, and change the layer the wire resides on. In addition, you can change the width of the wire, the end and join styles, and the angle of a Miter join. (See Wire Styles for more information on end and join styles of wires.)
**Circles**

The coordinates of the center, the radius, the data type, and the layer a circle resides on are modified with the **Edit Object(s) – Circles** tab.

![Edit Object(s) - Circles](image-url)
**Ports**

The coordinates of a port, the layer it resides on, the data type, and the text size, and value are changed with the *Edit Object(s) – Ports* tab. Default port text size is set with the *Setup Design – Drawing* command.
Rulers

Rulers are modified with the **Edit Object(s) – Rulers** tab. You can modify the layer it resides on, the data type, text and tick mark properties, the ruler end style, and the start and end point coordinates. Default ruler settings are set with the **Setup Design – Drawing** command.
Instances

Instances are modified with the **Edit Object(s) – Instances** tab. You can change the name of the instance and factors that affect the display of the instance.
Multiple Object Editing

You can use the Edit > Edit Object(s) command to modify multiple selected objects simultaneously.

Each tab in the Edit Object(s) dialog contains the number of selected objects of that type next to the name on the tab. When multiple objects with different properties are selected, the affected fields appear as dark gray to represent that multiple values exist for those properties:
This is called *mixed-value appearance*. Unlike disabled light gray or “grayed-out” fields, fields with the mixed-value appearance can be edited. All selected objects take on the value entered in one of these fields. If the **On layer** drop-down list or **Data type** is modified, all selected objects of all types will take on the entered value.

**Note:**

If multiple polygons or wires are selected, the **Vertices** list is disabled. If multiple instances are selected, both the **Instance of cell** and **Instance name** fields are disabled. Instances are not affected by **On layer** or **Data type** changes in the **Edit Object(s)** dialog.
Copying and Duplicating Objects

You can copy objects in two ways. The Edit > Copy command puts a copy of the selected object(s) in the internal paste buffer. The copy does not appear in the layout; it must be placed with the Edit > Paste command (see Pasting Objects).

The Edit > Duplicate command places a copy of the selected object(s) in the layout, selected and offset both horizontally and vertically by one grid point from the original. An exception to this is if a duplicate has already been made with the Duplicate command and dragged to another position. (See Repeated Copying of Objects, below.)

Multiple objects to be copied simultaneously must be explicitly selected. (For more information see Explicit Selection.)

Repeated Copying of Objects

As you drag a copy made with the Duplicate command into a new position, L-Edit keeps track of the object’s offset relative to the original. If the Duplicate command is executed and the new object is moved, subsequent Duplicate operations will create new objects that are automatically offset by the previous move amount. In this way arrays can be generated quickly and accurately since only the first copy needs to be positioned; if it is positioned correctly, all others will automatically be aligned.
Multiple placement of the same object can be useful in making regularly structured schematics, but it can also result in designs that use up a great deal of memory and are difficult to update. Multiple placement of the same object should not be used as a substitute for good hierarchical design using Instances.

The complete contents of an entire cell can be copied or added as an instance into another cell with the Cell > Copy and Cell > Instance commands.

**Copying to the Clipboard**

Large areas of the layout can be copied as a bitmap to the external clipboard with the Edit > Clipboard > Copy Window and Edit > Clipboard > Copy Selections commands. These bitmap images can be pasted into other applications; they cannot be pasted back into L-Edit. The resolution of the bitmap is the same as that of the screen.
Pasting Objects

L-Edit maintains an internal paste buffer that stores cut and copied objects. It can be used to transfer objects between cells or between layers within a file. The Edit > Paste command places the stored object(s) in the center of the active layout window, unless the Paste to cursor feature (see below) is enabled. The Edit > Paste to Layer command also places the stored object in the center of the Work Area of the active cell (unless the Paste to cursor feature is enabled), but places the object on the layer currently selected in the Layer Palette. Pasted objects are automatically selected after execution of the paste command.

Note: Objects on different layers can be selected and then pasted to a single layer with the Paste to Layer command.

The contents of the paste buffer can be pasted multiple times. Objects in the paste buffer are maintained until another object is cut or copied, or until the file is closed.

Paste-to-Cursor Feature

If the Paste to cursor box in the Setup Application – Keyboard dialog is turned on, the contents of the paste buffer appear in the Work Area but move with the pointer until any mouse button is clicked. The objects are then positioned at the
location of the cursor when the paste command is executed. Before the mouse button is clicked, the objects may be rotated or flipped horizontally or vertically by using the keyboard shortcut commands. (See Draw Menu for a list of default shortcut commands.)
Deleting Objects

You can remove objects from the layout in two ways. The Edit > Cut command puts the deleted objects into the paste buffer. From there they can be restored to the current cell or pasted into another cell in the same file (see Pasting Objects).

The Edit > Clear command does not put the deleted objects into the paste buffer. They can be restored to the active cell only with the Edit > Undo command (see Undoing Operations).
Undoing Operations

L-Edit maintains a list of edited objects and operations on a per cell basis in the undo buffer. Executing Edit > Undo reverses the last operation performed in a cell. You may continue undoing your operations, one at a time, up to and including the first operation on the cell since opening or saving it. L-Edit maintains a separate undo buffer for each cell.

Undo reverses mouse-based draw, move, edit, and copy operations. It also reverses the following commands:

- Edit > Cut
- Edit > Paste
- Draw > Group
- Draw > Ungroup
- Draw > Rotate
- Draw > Flip > Horizontal
- Draw > Flip > Vertical
- Draw > Slice > Horizontal
- Draw > Slice > Vertical
- Draw > Merge
Finding and Editing Objects

Undoing Operations

- Cell > Instance

The following operations clear the undo buffer:

- File > Save
- File > Save As
- File > Replace Setup
- Cell > Revert Cell
- Cell > Flatten
- Tools > Generate Layers
- Tools > DRC

Editing performed prior to any of these operations cannot be reversed with the Undo command.

Redo

You can reverse an Undo command with the Edit > Redo command.

After an Undo operation is performed, the object or operation goes into a redo buffer, also maintained by L-Edit on a per-cell basis. After an Undo operation, the Redo command becomes enabled, allowing you to revert the cell to its state before the Undo command was executed. For example: If you draw a box and
then click **Undo**, the box disappears from the layout. Clicking **Redo** causes the box to reappear.

Like the undo buffer, the redo buffer is maintained separately for each cell. The redo buffer is subject to the same guidelines and restrictions as the undo buffer, and it is cleared by the same methods. When editing continues, the redo buffer is cleared.

The depth of both buffers is limited only by computer resources.