Creating and Viewing Layout

- Drawing Layout
- Selecting and Deselecting Layout
- Moving Layout
- Viewing Layout
- Showing and Hiding Layout
Drawing Layout

The basic task in designing layout is drawing objects, which represent the elements and patterns of the circuitry to be fabricated.

After the current layer has been specified in the Layer palette (see Layer Palette), drawing an object involves two basic steps: (1) activating a drawing tool and (2) executing a drawing operation.

Drawing Tools

Object Types

There are several types of drawable objects. Each object type is associated with a tool which is activated to draw the corresponding object.

<table>
<thead>
<tr>
<th>Object type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Box</td>
<td>A shape characterized by four 90° corners.</td>
</tr>
<tr>
<td>Polygon</td>
<td>A shape characterized by an arbitrary number of vertices connected by straight edges to form a closed (possibly self-intersecting) figure.</td>
</tr>
</tbody>
</table>
### Object type

<table>
<thead>
<tr>
<th><strong>Object type</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Wire</td>
<td>A shape consisting of one or more rectangular segments, of equal width, joined at common ends.</td>
</tr>
<tr>
<td>Circle</td>
<td>A shape characterized by a center (point) and a radius.</td>
</tr>
<tr>
<td>Arc</td>
<td>A section of a circle characterized by a center, a radius, and a sweep angle.</td>
</tr>
<tr>
<td>Torus</td>
<td>A section of a circle characterized by a center, two radii (inner and outer), and a sweep angle.</td>
</tr>
<tr>
<td>Port</td>
<td>A point or box with associated text, used to label layout for documentation purposes.</td>
</tr>
<tr>
<td>Ruler</td>
<td>A line with a choice of end styles and optional tick marks, used to measure layout for documentation purposes.</td>
</tr>
<tr>
<td>Instance</td>
<td>A symbolic representation of a cell at a specific location and orientation in another cell.</td>
</tr>
</tbody>
</table>
**Drawing Toolbar**

The drawing tools are represented by buttons in the Drawing toolbar.

- Selection tool
- Box tool
- Polygon tool — orthogonal
- Polygon tool — 45 degrees
- Polygon tool — all angle
- Wire tool — orthogonal
- Wire tool — 45 degrees
- Wire tool — all-angle
- Circle tool
- Arc tool
- Torus tool
- Port tool
- Ruler tool — orthogonal
- Ruler tool — 45 degrees
- Ruler tool — all angle
- Instance tool

To activate a drawing tool, click its toolbar button with the CHOOSE mouse button. The button corresponding to the active tool is highlighted.

All objects drawn are of the active tool’s type until another tool is activated.

The selection tool does not create new objects; instead, it is used for object selection.
The Drawing toolbar itself can be displayed in three modes: orthogonal, 45 degrees, and all angle.

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orthogonal</td>
<td>Only buttons for the <em>orthogonal</em> mode of the polygon, wire, and ruler tools are shown; those for the circle, arc, and torus tools are not shown.</td>
</tr>
<tr>
<td>45 degrees</td>
<td>Only buttons for the <em>orthogonal</em> and <em>45 degrees</em> modes of the polygon, wire, and ruler tools are shown; those for the circle, arc, and torus tools are not shown.</td>
</tr>
<tr>
<td>All angle</td>
<td>Buttons for all three modes — <em>orthogonal</em>, 45 <em>degrees</em>, and <em>all angle</em> — of the polygon, wire, and ruler tools, as well as for the circle, arc, and torus tools, are shown.</td>
</tr>
</tbody>
</table>
There are two ways to control the display mode of the Drawing toolbar.

- In the drawing toolbar, click the MENU button; in the resulting pop-up menu, check one of the Orthogonal, 45 Degrees, or All Angle options.
- In the dialog opened by the Setup > Application command, choose an option from the Drawing mode drop-down list (under the General tab, in the Toolbars section).

**Drawing Operations**

The starting point for drawing any object is its anchor point. With a drawing tool activated and the crosshair pointer positioned at the anchor point, click the DRAW button to start drawing an object.

**Drawing Boxes**

The anchor point is one of the corners of the box.

Drag (holding the DRAW button) away from the anchor point to determine the opposite corner (and therefore the length and width) of the box. Release the DRAW button at the desired opposite corner.

**Drawing Circles**

The anchor point is the center of the circle.
Drag (holding the DRAW button) away from the anchor point to determine the radius of the circle. Release the DRAW button at the desired radius.

**Drawing Arcs**

The anchor point is the center of the arc.

When the arc tool is clicked at the anchor point, the mouse buttons become the VERTEX, BACKUP, and END buttons.

Move (without holding a button) or drag (holding the VERTEX button) away from the anchor point to determine the radius of the arc (indicated by a thin line). Click or release the VERTEX button at the desired radius.

If (before the radius has been finalized) a different anchor point is desired, then click the BACKUP button. The pointer can then be moved freely to another anchor point.

After clicking at the radius, move (do not drag) away from this point to determine the sweep angle of the arc. Click either the VERTEX button or the END button at the desired sweep angle.

- Dragging in a *counterclockwise* direction about the anchor point produces an arc with a *positive* sweep angle.
- Dragging in a *clockwise* direction about the anchor point produces an arc with a *negative* sweep angle.
If (before the sweep angle has been finalized) a different radius is desired, then click the BACKUP button. The pointer can then be moved to find another radius; the thin line showing the radius is a different color (to indicate correction).

**Drawing Tori**

The anchor point is the center of the torus.

When the torus tool is clicked at the anchor point, the mouse buttons become the VERTEX, BACKUP, and END buttons.

Move (without holding a button) or drag (holding the VERTEX button) away from the anchor point to determine the first radius of the torus (indicated by a thin line). Click or release the VERTEX button at the desired first radius.

If (before the first radius has been finalized) a different anchor point is desired, then click the BACKUP button. The pointer can then be moved freely to another anchor point.

After clicking at the first radius, move (do not drag) away from this point to determine both the sweep angle and the second radius of the torus. Click either the VERTEX button or the END button at the desired sweep angle and second radius.

- Dragging in a *counterclockwise* direction about the anchor point produces a torus with a *positive* sweep angle.
• Dragging in a \textit{clockwise} direction about the anchor point produces a torus with a \textit{negative} sweep angle.

If (before the sweep angle and second radius have been finalized) a different radius is desired, then click the BACKUP button. The pointer can then be moved to find another radius; the thin line showing the radius is a different color (to indicate correction).

\textit{Drawing Polygons and Wires}

The anchor point is the first vertex of the polygon or wire.

When the polygon tool is clicked at the anchor point, the mouse buttons become the VERTEX, BACKUP, and END buttons.

Move (without holding a button) or drag (holding the VERTEX button) away from the anchor point to determine the second vertex position. Click or release the VERTEX button at the desired vertex position.

Repeat this step for each successive vertex. Polygons and wires can have any number of vertices.

Clicking the BACKUP button removes the most recently placed vertex. The pointer can then be moved to another position for that vertex.

Click the END button at the last vertex.
When the END button is clicked, coincident vertices (two or more vertices occupying the same location) and colinear vertices (three or more vertices lying on the same straight line) are eliminated.

The appearance of the vertices of wires is determined by the default wire style for the current layer. To modify these parameters, use the **Setup > Layers** command.

The appearance of a wire on the screen does not necessarily reflect the way in which it will be fabricated. *Just because a wire appears to touch another object on the screen does not necessarily mean that it will form a connection when the chip is fabricated.*

**Drawing Ports**

A port can be 0-dimensional (a point) or 2-dimensional (a box). (Ports can also be 1-dimensional, or lines; these are special cases of box ports.)

- For a *point* port, the anchor point is the location of the port.
- For a *box* (or line) port, the anchor point is the corner of the port.

To draw a point port, release the DRAW button after clicking at the anchor point.

To draw a box port, drag (holding the DRAW button) away from the anchor point to determine the opposite corner and therefore the length and width of the box. Release the DRAW button at the desired opposite corner.
When the DRAW button is released, a dialog appears, asking for the name of the port and the size of the text used to display the name. Enter this information and click OK (or Cancel to remove the port).

To modify the default port text size, use the Setup > Design command (under the Drawing tab).

**Drawing Rulers**

The anchor point is one of the endpoints of the ruler. Drag (holding the DRAW button) away from the anchor point to determine the other endpoint (and therefore the length and orientation) of the ruler.

To modify default ruler settings, use the Setup > Design command; in the dialog, choose options in the Default ruler settings and Create rulers on sections under the Drawing tab.

To modify settings for a specific (selected) ruler, *either* use the Edit > Edit Object(s) command *or* double-click the MOVE-EDIT button on the ruler; in the dialog, choose options under the Rulers tab.

**Drawing Instances**

Clicking the instance tool button produces the same dialog as that opened by the Cell > Instance command.
Selecting and Deselecting Layout

Definitions and Displays

*Selecting* an object ensures that subsequent editing operations will affect that object specifically. More than one object may be selected at a time.

*Deselecting* a selected object revokes its selected status.

By default, selected objects are outlined. It is possible to change the manner in which selection is displayed on any given layer by modifying the layer’s pass specification (see Pass Lists).

When multiple views of the same cell are open, selected objects are displayed as such in all of the views.

When a selected object is part of an instance, it is displayed as such only in its original (instanced) cell.

For information on *selection* and *deselection* ranges, see Replacing the Setup.
## Actions

There are several actions related to selection and deselection, performed *with the selection tool active*.

These actions involve clicking appropriate mouse buttons in or near the object to be selected (within the *selection range*).

<table>
<thead>
<tr>
<th>Action</th>
<th>Mouse button</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Explicitly selecting</em> an object or set of</td>
<td>SELECT</td>
</tr>
<tr>
<td>objects, before an operation is performed</td>
<td></td>
</tr>
<tr>
<td><em>Implicitly selecting</em> an object, in the</td>
<td>MOVE-EDIT</td>
</tr>
<tr>
<td>process of performing an operation on it</td>
<td></td>
</tr>
<tr>
<td><em>Adding (extend selecting)</em> an object to a</td>
<td>EXTEND SELECT (Shift+SELECT)</td>
</tr>
<tr>
<td>set of selected objects</td>
<td></td>
</tr>
<tr>
<td><em>Subtracting (deselecting)</em> an object from</td>
<td>DESELECT (Alt+right SELECT)</td>
</tr>
<tr>
<td>a set of selected objects</td>
<td></td>
</tr>
</tbody>
</table>
Selecting

Explicit Selection

To explicitly select an object by clicking, position the pointer over the object to be selected and click the SELECT button. Any previously selected objects are automatically deselected.

To explicitly select a set of objects by dragging:

- Position the pointer outside a corner of the set of objects to be selected.
- Drag the pointer with the SELECT button held, forming a selection marquee around the objects.
- Position the opposite corner of the selection marquee so that the marquee completely encloses all the objects to be selected but does not completely enclose any other objects, and release the SELECT button.

Any objects completely contained within the selection marquee are selected. Any previously selected objects are automatically deselected.

Cycle Selection

Clicking near or in several objects selects the closest object. The next click with the pointer in the same spot deselects the object just selected and selects the next closest object (within the selection range).
Repeated clicks progressively select nearby objects until there are no more objects within the selection range. The next click deselects all objects. The following click starts with the closest object again.

**Extend Selection**

To extend a selection to another object or group of objects, adding it to the set of already selected objects, select the object(s) with the EXTEND SELECT (Shift+SELECT) button. Previously selected objects are *not* deselected.

**Implicit Selection**

If no other objects are selected, pressing and holding the MOVE-EDIT button in or near an object (within the selection range) selects that object and begins a move or edit operation.

Unless the pointer is far enough (outside the deselection range) from all previously selected objects, these objects are *not* deselected by attempting to select another object implicitly, and may be moved instead of the target object! There are several ways to avoid this potential problem:

- Precede an implicit selection with the **Edit > Deselect All** command (see Universal Deselection).
- Set the deselection range appropriately.
**Universal Selection**

All objects in the active cell may be selected with the `Edit > Select All` (Ctrl+A) command.

**Picking Layers**

The `Draw > Pick Layer` (A) command changes the current layer to the layer of the last selected object (excluding instances). If there are no objects selected, the current layer changes to the layer of the object closest to the pointer.

**Deselecting**

**Explicit Deselection**

To deselect a selected object without affecting other selected objects, click it (or drag around a set of selected objects) with the DESELECT (Alt+right SELECT) button.

Clicking the DESELECT button over an object which is not selected, or far enough (outside the selection range) from all selected objects, has no effect.
**Implicit Deselection**

Clicking the SELECT button far enough (outside the selection range) from all selected objects automatically deselects them.

Clicking the MOVE-EDIT button near an object to be implicitly selected and far enough (outside the deselection range) from all previously selected objects automatically deselects them.

**Hidden Deselection**

When a layer is hidden, all selected objects on that layer are automatically deselected. This prevents hidden objects from being moved or edited. These objects remain deselected even after they are made visible again.

**Universal Deselection**

*All* objects in the active cell may be deselected with the Edit > Deselect All (Alt+A) command.
Moving Layout

Graphical Repositioning

To move an object, select it and position the pointer anywhere except on a vertex or edge of the selected object. Holding the MOVE-EDIT button, drag the object to its new position.

A single object can be implicitly selected and moved by clicking the MOVE-EDIT button in or near it (but not on a vertex or edge) and dragging the object to its new position. The object is automatically deselected after the move.

Multiple objects to be moved simultaneously must all be explicitly selected. The pointer may be initially positioned anywhere, including on any vertex or edge. When moved, the selected objects’ relative positions are maintained.

To enable snapping — that is, to constrain movement to the horizontal or vertical directions only — hold the Shift key down while using the MOVE-EDIT button.

The MOVE-EDIT button’s function changes depending on the position of the pointer:

- If the pointer is on or sufficiently near a vertex or edge of a single selected object, then an edit is performed.
If the pointer is anywhere else, then a *move* is performed.

The distance from a vertex or edge at which an edit, rather than a move, is performed can be specified with the **Setup > Design** command (under the **Selection** tab).

### Incremental Repositioning

Four commands incrementally move (*nudge*) a selected object or set of objects over a predetermined distance.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw &gt; Nudge &gt; Left</td>
<td>Ctrl + ←</td>
</tr>
<tr>
<td>Draw &gt; Nudge &gt; Right</td>
<td>Ctrl + →</td>
</tr>
<tr>
<td>Draw &gt; Nudge &gt; Up</td>
<td>Ctrl + ↑</td>
</tr>
<tr>
<td>Draw &gt; Nudge &gt; Down</td>
<td>Ctrl + ↓</td>
</tr>
</tbody>
</table>

The nudge amount can be specified with the **Setup Design – Drawing** dialog.
Numerical Repositioning

Selected objects can also be moved specified distances with the Draw > Move By command. In the dialog, enter values for the Move amount along the X and Y axes, and click OK.

Reorienting

Three commands change the orientation of selected objects.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw &gt; Rotate</td>
<td>R</td>
<td>Rotates the selected object by 90° counter-clockwise about its geometrical center.</td>
</tr>
</tbody>
</table>
When multiple objects are selected, the rotation or flip occurs about the geometrical center of the selected group.
Viewing Layout

Each window shows a portion of a cell’s layout. The subset of the layout displayed in the window is called the view.

The view in the active window can be moved (panned) to show a different area of the layout, or magnified (zoomed) to show a larger or smaller area of the layout.

Panning and zooming can be done at any time while drawing, moving, or editing layout.

Panning

The nine panning commands act on the view in the active cell window. It is the view that is moved, not the objects; thus, moving the view in one direction causes apparent motion of visible objects in the other direction.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Pan &gt; To Selections</td>
<td>Y</td>
<td>Moves the view until it is centered as much as possible over the selected objects.</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>View &gt; Pan &gt; Left</td>
<td>←</td>
<td>Moves the view to the left by one-quarter of the width of the view.</td>
</tr>
<tr>
<td>View &gt; Pan &gt; Right</td>
<td>→</td>
<td>Moves the view to the right by one-quarter of the width of the view.</td>
</tr>
<tr>
<td>View &gt; Pan &gt; Up</td>
<td>↑</td>
<td>Moves the view up by one-quarter of the height of the view.</td>
</tr>
<tr>
<td>View &gt; Pan &gt; Down</td>
<td>↓</td>
<td>Moves the view down by one-quarter of the height of the view.</td>
</tr>
<tr>
<td>View &gt; Pan &gt; To Cell Edge &gt; Left</td>
<td>Shift + ←</td>
<td>Moves the view until its edge is flush with the leftmost edge among all objects in the cell.</td>
</tr>
<tr>
<td>View &gt; Pan &gt; To Cell Edge &gt; Right</td>
<td>Shift + →</td>
<td>Moves the view until its edge is flush with the rightmost edge among all objects in the cell.</td>
</tr>
</tbody>
</table>
Auto-Panning

When auto-panning is on, moving the pointer to one of the edges of the view automatically initiates a pan in the corresponding direction.

To activate auto-panning, use the Setup > Application command: under the General tab, check the Auto-panning option.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Pan &gt; To Cell Edge &gt; Up</td>
<td>Shift + ↑</td>
<td>Moves the view until its edge is flush with the topmost edge among all objects in the cell.</td>
</tr>
<tr>
<td>View &gt; Pan &gt; To Cell Edge &gt; Down</td>
<td>Shift + ↓</td>
<td>Moves the view until its edge is flush with the bottommost edge among all objects in the cell.</td>
</tr>
</tbody>
</table>
Zooming

The four zooming commands act on the view in the active cell window. Increasing the magnification causes objects to look larger; decreasing the magnification causes objects to look smaller.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Home</td>
<td>Home</td>
<td>Changes the view to encompass as closely as possible all objects in the cell.</td>
</tr>
<tr>
<td>View &gt; Zoom &gt; In</td>
<td>+</td>
<td>Doubles the magnification.</td>
</tr>
<tr>
<td>View &gt; Zoom &gt; Out</td>
<td>–</td>
<td>Halves the magnification.</td>
</tr>
<tr>
<td>View &gt; Zoom &gt; To Selections</td>
<td>W</td>
<td>Changes the view to encompass as closely as possible only the selected objects (except text associated with ports).</td>
</tr>
</tbody>
</table>
When an instance is being edited in-place (see Editing In-Place), **Home** zooms to the cell being edited, whereas **End** zooms to the root cell.

### Mouse-Controlled Viewing

The **View > Zoom > Mouse (Z)** command changes the functions of the mouse buttons for a single operation. The three buttons become the ZOOM BOX button, the PAN button, and the ZOOM OUT button.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
</table>
| ZOOM BOX    | - **Clicking** at a single point magnifies the area around the pointer by a factor of two.  
- **Dragging** specifies a rectangle to which the view will be zoomed (as closely as possible while maintaining the height-to-width ratio) when the button is released. |
| PAN         | - **Clicking** pans the view so that the new center is located at the pointer’s position.  
- **Dragging** pans the view in the direction and through the distance of the pointer’s motion (when the button is released). |
| ZOOM OUT    | - **Clicking** zooms the display window out from the location of the pointer. |
After a mouse-controlled viewing operation, the mouse buttons revert to the DRAW, MOVE-EDIT, and SELECT functions.

**Exchanging Views**

L-Edit remembers the view before executing a new pan or zoom command. The View > Exchange (X) command returns to the previous view. The two views may be exchanged back and forth.
Showing and Hiding Layout

On a crowded layout, it may be desirable to hide certain features in order to be able to focus more effectively on others. The effect of hiding is reversed by showing.

Showing and hiding commands apply to all cells in the current file.

Showing and Hiding Objects

All objects of a specific type — boxes, for example — can be hidden, or shown if already hidden, as a group. Hidden objects cannot be drawn, selected, moved, deleted, or edited.

Objects can be shown and hidden effectively only on shown layers.

In the drawing toolbar, hidden object types are indicated by shaded buttons. Tools can still be activated even in the hidden state, but the corresponding objects cannot be drawn.
**Showing and Hiding Specific Object Types**

There are three ways to show or hide all objects of a specific type.

<table>
<thead>
<tr>
<th>Location</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing toolbar</td>
<td>Click the HIDE/SHOW button over a tool to toggle the state of the corresponding type.</td>
</tr>
<tr>
<td>Drawing toolbar</td>
<td>Click the MENU button over a tool; in the pop-up menu, check (to show) or uncheck (to hide) the Show option.</td>
</tr>
<tr>
<td>View &gt; Objects submenu</td>
<td>Check (to show) or uncheck (to hide) the desired type.</td>
</tr>
</tbody>
</table>

**Showing and Hiding All Object Types**

There are three ways to show or hide all objects of all (or almost all) types.

<table>
<thead>
<tr>
<th>Location</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing toolbar</td>
<td>Click the H/S ALL (Ctrl+HIDE/SHOW) button over a tool.</td>
</tr>
<tr>
<td>Location</td>
<td>Action</td>
</tr>
<tr>
<td>---------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Over the selection tool, the H/S ALL button</td>
<td>shows or hides all object types.</td>
</tr>
<tr>
<td>Over the box, wire, circle, port, ruler, or instance tools, the H/S ALL button</td>
<td>shows the corresponding type and shows or hides all other types.</td>
</tr>
<tr>
<td>Over any of the polygon, arc, or torus tools, the H/S ALL button</td>
<td>shows polygons, arcs, and torii, and shows or hides all other types.</td>
</tr>
<tr>
<td>Drawing toolbar</td>
<td>Click the MENU button over a tool; in the popup menu, check <strong>Show All</strong> or <strong>Hide All</strong>.</td>
</tr>
<tr>
<td>Over the selection tool, these options show or hide all types.</td>
<td></td>
</tr>
<tr>
<td>Over the box, wire, circle, port, ruler, or instance tools, these options show the corresponding type and show or hide all other types.</td>
<td></td>
</tr>
<tr>
<td>Over any of the polygon, arc, or torus tools, these options show polygons, arcs, and torii, and show or hide all other types.</td>
<td></td>
</tr>
</tbody>
</table>
A hidden layer is one on which all objects are invisible. Objects on hidden layers cannot be drawn, selected, moved, deleted, or edited.

In the layer palette, hidden layers are indicated by shaded icons. Layers can be selected even in the hidden state.

**Showing and Hiding Specific Layers**

There are four ways to show or hide a specific layer.

<table>
<thead>
<tr>
<th>Location</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer palette</td>
<td>Click the HIDE/SHOW button over a layer icon to toggle its state.</td>
</tr>
</tbody>
</table>
There are four ways to show or hide all (or almost all) layers.

<table>
<thead>
<tr>
<th>Location</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer palette</td>
<td>Click the MENU button over a layer icon; in the pop-up menu, check (to show) or uncheck (to hide) the <strong>Show Name</strong> option (where <strong>Name</strong> is the name of the layer).</td>
</tr>
<tr>
<td>View &gt; Layers submenu</td>
<td>Check (to show) or uncheck (to hide) the <strong>Show Name</strong> option (where <strong>Name</strong> is the name of the current layer).</td>
</tr>
<tr>
<td>Setup &gt; Layers dialog</td>
<td>Under the <strong>General</strong> tab, check (to hide) or uncheck (to show) the <strong>Hidden</strong> option for the layer highlighted in the <strong>Layers</strong> list.</td>
</tr>
</tbody>
</table>

**Showing and Hiding All Layers**

There are four ways to show or hide all (or almost all) layers.

<table>
<thead>
<tr>
<th>Location</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer palette</td>
<td>Click the H/S ALL (Ctrl+HIDE/SHOW) button over a layer icon. The layer is shown. If all other layers are hidden, they are shown; if all other layers are shown, they are hidden</td>
</tr>
</tbody>
</table>
Creating and Viewing Layout

Showing and Hiding Layers

The layer palette pop-up menu and the View > Layers submenu contain two additional options.

- **Show Generated**: Shows all generated layers.
- **Hide Generated**: Hides all generated layers.

Showing and Hiding Generated Layers

- **Show All**: to show all layers; check **Show All** to show all layers, or **Hide All** to hide all other layers.
- **View > Layers** submenu

Showing and Hiding Hierarchy

*Insides*

Hiding instance *insides* (the objects contained by instanced cells) can speed up screen redraw and clarify the layout at relatively small magnifications.
Instances whose insides are hidden are displayed in “outline” mode. They can still be selected (whereas hidden instances are completely invisible and cannot be selected).

The name of the instanced cell is displayed with the instance outline unless the name would extend beyond the edges of the outline.

There are several ways to control the visibility of instance insides.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Insides &gt; Toggle Insides</td>
<td>Ctrl+I</td>
<td>Toggles the visibility of the insides of all instances on visible layers at all levels of the hierarchy — except ports.</td>
</tr>
<tr>
<td>View &gt; Insides &gt; Show Insides</td>
<td>S</td>
<td>Shows the insides of the selected instance(s).</td>
</tr>
<tr>
<td>View &gt; Insides &gt; Hide Insides</td>
<td>D</td>
<td>Hides the insides of the selected instance(s).</td>
</tr>
<tr>
<td>View &gt; Insides &gt; Hide Leaves</td>
<td>Alt+L</td>
<td>Hides all leaf-level cells in the hierarchy.</td>
</tr>
</tbody>
</table>
**View > Icon** command modifies the visibility of (otherwise hidden) instance insides.

- **Checked**
  - Any (otherwise hidden) instance insides on the Icon layer are shown.

- **Unchecked**
  - All hidden instance insides stay hidden.
Arrays

The View > Arrays command controls the visibility of arrays (if they are not part of hidden instance insides).

Checked
Arrays are shown in full, with all repeated geometry visible.

Unchecked
Arrays are displayed as single instances, with only one element per array visible.

Ports

The View > Ports command controls the visibility of ports within instances.

Checked
Ports within instances are shown.

Unchecked
Ports within instances are hidden.
Showing and Hiding Interface Elements

**Grid**

The View > Grid command controls the visibility of the displayed grid (not the mouse snap grid), if the Grid layer is not hidden.

- **Checked**: The grid is shown (if the magnification allows).
- **Unchecked**: The grid is hidden.

**Origin**

The View > Origin command controls the visibility of the crosshair marker that indicates the origin (0,0), if the Origin layer is not hidden.

- **Checked**: The origin is shown (if it is within the view).
- **Unchecked**: The origin is hidden.